Honda Grom banner
1 - 15 of 15 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi guys, I’m new to the grom (and motorcycle) community and I have recently installed a straight up pumps oil pump and a kitaco clutch cover. The problem is that whenever I start up after the bike has been sitting for a while it gives a low pitched squeal. After turning off and restarting the bike around 3 times the sound goes away. I was just wondering if this was an issue with the oil pump or something else. I can give a video if need be. Thanks in advance!
 

·
Registered
Joined
·
896 Posts
starting an engine its the max wear peak. did you oil everything while installing the ex.oil.spinner kit ?
bike runs smooth ?

keep it monitored...
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
starting an engine its the max wear peak. did you oil everything while installing the ex.oil.spinner kit ?
bike runs smooth ?

keep it monitored...
Yes I oiled it all. Put oil on all the bearings and such. I did snap a bolt on the oil pump but it still had two bolts on it so it should be secure. Plus the hole that it snapped off in has a metal stud to prevent back/forth motion.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Let's see/hear a video. I would fix that oil pump too.
I will as soon as I’m able to. I’ve found that the sound only happens when the bike is cold and wet. Also in regards to the oil pump, how do you recommend I get that out and replace it? Where can I get a replacement bolt?
 

·
Registered
Joined
·
8,407 Posts
I will as soon as I’m able to. I’ve found that the sound only happens when the bike is cold and wet. Also in regards to the oil pump, how do you recommend I get that out and replace it? Where can I get a replacement bolt?
go on your computer and look up Honda grom parts from local MC store near you or on the net, they will have various drop down tabs you have to go thru to get to the model you have than it will have a selection of engine, frame, wheels, etc, select Engine and OEM parts and look up the part and order online.

good luck
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
go on your computer and look up Honda grom parts from local MC store near you or on the net, they will have various drop down tabs you have to go thru to get to the model you have than it will have a selection of engine, frame, wheels, etc, select Engine and OEM parts and look up the part and order online.

good luck
Thank you! Will do as soon as I have some spare time.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
starting an engine its the max wear peak. did you oil everything while installing the ex.oil.spinner kit ?
bike runs smooth ?

keep it monitored...
Update, it hasn’t been doing it as much. Only when the bike gets really cold. When this happens the bike seems to have a harder time reaching top speed than normal. Maybe the oil is just really cold? Other than that the bike is running better than ever. Any words of advice?
 

·
Registered
Joined
·
1,089 Posts
Use a screwdriver to your ear and put the other end at various parts of your motor, while a friend starts the bike. A DIY stethoscope! You will soon zoom in on the area that is making the noise.

I would first start at the fuel injector and work around the motor.

Yes fix the oil pump issue. No matter what the cost...
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #13 ·
Thanks to everyone for your suggestions. I have taken everything apart and put it all back together how it should be. I haven’t heard the sound since. I appreciate the help and wish everyone well. Ride on.
 

·
Registered
Joined
·
121 Posts
Interesting. That starter sounds weak too. Maybe a low battery or starter motor issue. Glad you got it fixed for now.
 

·
Registered
Joined
·
1 Posts
Use a screwdriver to your ear and put the other end at various parts of your motor, while a friend starts the bike. A DIY stethoscope! You will soon zoom in on the area pornjk porn800 redtube that is making the noise.

I would first start at the fuel injector and work around the motor.

Yes fix the oil pump issue. No matter what the cost...
After turning off and restarting the bike around 3 times the sound goes away. I was just wondering if this was an issue with the oil pump or something else. I can give a video if need be. Thanks in advance!
 
1 - 15 of 15 Posts
Top