Honda Grom banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
the main problem is I own the only grom in North cyprus they have no experience here with these kind of engines! I am afraid that the engine will break up
 

·
Registered
Joined
·
106 Posts
I’d say for people to help more info is needed like who is the reflash ecu from and even a video of the bike running with ticking sound would be good.
 
  • Like
Reactions: aliradwan

·
Super Moderator
2020 Honda Grom
Joined
·
984 Posts
Proabably needs a valve adjustment, the air box blocked most of the sound. Now that it is gone, you can hear the valvetrain noise. How many miles on the bike? When was the last adjustment done?
 

·
Registered
Joined
·
164 Posts
ticking usually indicates valve adjustment, definitely check to make sure your valves are in spec.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Just did the adjustment last night and it still making the same sound , I will upload the video soon i really appreciate it
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Proabably needs a valve adjustment, the air box blocked most of the sound. Now that it is gone, you can hear the valvetrain noise. How many miles on the bike? When was the last adjustment done?
While re doing the adjustment I found a scratching on the value caps, I think its from the value hitting the value cover ? I will adjust it again tomorrow, this grom page is great 👍
ticking usually indicates valve adjustment, definitely check to make sure your valves are in spec.
While doing the adjustment I found scratches on the valve cover from the inside!! Adjusted it but still Making the ticking sound
 

·
Registered
Joined
·
43 Posts
If you don't have a feeler gauge then you can use the other method which is to tigthen the
While re doing the adjustment I found a scratching on the value caps, I think its from the value hitting the value cover ? I will adjust it again tomorrow, this grom page is great 👍
While doing the adjustment I found scratches on the valve cover from the inside!! Adjusted it but still Making the ticking sound
You haven't got a loose nut in there?
 
1 - 8 of 8 Posts
Top