Honda Grom banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I noticed today my 2017 is having headlight issues. Everything else works perfectly. Blinkers, speedo, license plate light. The headlights are INCREDIBLY dim, both high and low beam. The high beam indicator comes on the cluster, but they hardly illuminate my hand directly in front of the light.

This is my first ride of the year. I had a dead battery, upgraded to a lithium battery. That is the only change. I rode the bike 100 miles with no issues at all with the new battery, and upon pulling into the garage noticed no headlight.

I found a wiring diagram, and at the headlight connector, between the brown/white and black/white wires I had ~12v with the bike running. To me, that tells me the headlight assembly itself is the issue. Is that correct? Should I check anything else before ordering a new light
 

·
Super Moderator
2020 Honda Grom
Joined
·
1,530 Posts
Double check your battery conections to make sure they are tight. It was the only change after all.
 

·
Registered
Joined
·
1 Posts
I noticed today my 2017 is having headlight issues. Everything else works perfectly. Blinkers, speedo, license plate light. The headlights are INCREDIBLY dim, both high and low beam. The high beam indicator comes on the cluster, but they hardly illuminate my hand directly in front of the light. This is my first ride of the year. I had a dead battery, upgraded to a lithium battery. That is the only change. I rode the bike 100 miles with no issues at all with the new battery, and upon pulling into the garage noticed no headlight. I found a wiring diagram, and at the headlight connector, between the brown/white and black/white wires I had ~12v with the bike running. To me, that tells me the headlight assembly itself is the issue. Is that correct? Should I check anything else before ordering a new light
Did you find the problem ?
 
1 - 3 of 3 Posts
Top