Honda Grom banner

1 - 3 of 3 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
so ya my grom is having some lame problem.. i thought was fuel pump related..
i replaced fuel pump fuel filter spark plug and got a new injector..
so how it started i would be wot.. then all a sudden would get small backfires.. and then lose power though it would still be running.. when try to give it gass.. it just bogs.. then dies.. at first it would start right back up when stopped..and be ready to keep going, now it takes a long time.. after i changed the parts it was cool for a couple days.. then today.. on way home from work.. died.. took 10 minutes to start again.. rode for 10 minutes then it die at bank.. took 35 minutes at bank.. then it start again and i got home no more stalls.. this shit sucks though.. have no idea what it could be.. most people dont.. even riders that have ridden for a very long time.. so over this shit.. first problem ive had with it.. and of course it has to be something that seems unsolvable.. 26k miles on it.. and ya first real problem..
i also had valves adjusted just cuz it was in shop.. but now im debating to take it to shop.. or to just save for a couple weeks and get a used 250 off craigslist.. i cant keep throwing money at this shit.. of course every post that talks about problems similiar never put conclusions.. which is why i hate forums .. anyways peace out.. rip my grom.
 

·
Registered
Joined
·
817 Posts
Have you tried an ignition coil? They have been known to quit working when they are hot and then cool off and work again.
 
  • Like
Reactions: David

·
Registered
Joined
·
784 Posts
Good suggestion from Ninelives.

When it's not working, did you check fuel and spark?
 
1 - 3 of 3 Posts
Top