Honda Grom banner

1 - 10 of 10 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
What would cause the Grom to randomly shut off and then have a hard time starting? I waited a few minutes and it started back up rpms stayed low like at 1k then a revved a little and it went back to normal?
 

·
Registered
Joined
·
1,034 Posts
Yea it sounds like the fuel pump recall
 

·
Registered
Joined
·
8,380 Posts
Not knowing if this is a new grom unmolested or BBK kit grom or second owner grom or what ever here is my take

How many miles is on the grom and what year?
Did you buy shitty gas or good gas?
Is the intake system modified such as airbox mod, radiator hose and such?

Look in your gas tank and check to see if you can see fuel.

Check your spark plug to make sure it is fully seated and torqued down and check your spark plug wire to make sure it is secured on the plug. Pull out the spark plug and check the condition of the plug.

If you mod your intake system check and make sure the Idle screw is set correctly.

Good luck
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
It died when I was coming to a stop with the clutch in. I'm guess it's the fuel pump recall. It's just funny how it was working fine this whole time and just a few days ago, I get the letter in the mail for the recall and then this happens lmao.

Btw im the 2nd owner
Chimera intake
Ejk tuner
Brocks exhaust
Everything's pretty much stock besides that
 

·
Registered
Joined
·
103 Posts
check your kill switch also. mines faulty an has like a short or something. i can literally tap the switch an make the bike shut off
 

·
Registered
Joined
·
256 Posts
My bike has less than 600 miles on it and this has happened to me 3 times so far, mine makes a little pop and then cuts out (a bit like a little back fire) it's when I'm trickling along in traffic on low rev's! I will mention this to the shop when in for it's 1st service.
 

·
Registered
Joined
·
62 Posts
this is what mine is doing and i just changed out every part but it still does it.. fuel pump. fuel fillter spark plug.. i even did a new injector.. and it didnt help... yes mine is doing the half ass backfires also right when it lose all power but it will still be running.. . you give it gas it bogs out but is running. then it will die after about 20 seconds... its really wierd.. but pissing me off bigtime.. since i replace the parts that should have fixed it.. so ya i have no clue what is wrong with mine.. the sad thing.. it runs like a champ when it doesnt do this .. 26k miles.. easily rolls at 60mph.. but then all a sudden pop.. stalls.. take forever to restart ... annoying..
 
1 - 10 of 10 Posts
Top