Honda Grom banner

BB Grom AF1 / RC5 Mini problems

563 Views 4 Replies 3 Participants Last post by  waspmike
Hi guys 馃憢,

new at this forum here, thx for having me... Excellent resource BTW 馃憣, learned alot here by reading the last 2 years !

I've owned a light bore 2014 MSX/Grom for 2 years now & had immense fun with this little bike.
Last week I had the opportunity to buy a very good looking and (kinda) maxed out 2015 BBore MSX & went for it.
The previous owner had difficulties with starting & getting it properly set up & didn't want to spend more time on it.
Upgrades only have 500 miles on em...
So bought it (cheap!) and now it's up to me to straighten things out & was hoping this community could help me / hear me out a bit ? I'm not a complete noob or so, but the ARacer injection/mapping shizzles is indeed new to me 馃槵

Specs:
  • Kitaco Neo 181cc (+-500 miles)
  • Kitaco Clutch Cover
  • Kitaco reinforced clutch plate
  • Takegawa 34mm Big throttle bodykit
  • Keihin IF20 NNJ injector (10 holes)
  • Dingerbuilt Short Ram intake
  • Takegawa Super Oil pump
  • Kitaco Super 3-row oil cooler
  • Full Aracer setup (AF1 module + RCmini 5)
  • Zoom Loop Exhaust with O2 bung

So drove it last week & indeed it didn't quite deliver (as the previous owner said)...
Low torque and sometimes hesitating to rev, but it was driveable.
The Zoom Loop exhaust however was extremely loud, even with DB-killer installed, so I decided to replace it with the Kepspeed (Madmunk) GP2 exhaust from my previous MSX just to hear the difference (sound is a big deal to me).
Sounding so much better I took it for a drive... Having no O2 bung on this exhaust, the Wideband sensor was exposed to open air.
Driving with this exhaust was night & day difference, massive torque, high speed, very responsive :D... Awesome to drive, was glad it was sorted & I was immediately hooked :p.

But then when I redlined it, it suddenly starts spluttering & stuttering and it died on me 馃槶.
Restarted it and got it home stuttering. Very difficult to start now & grey smoke coming out of the exhaust.
Now I'm anxious that something serious has gone wrong 馃槪... Any ideas ?

So I'm guessing the (open) O2 sensor will be to blame ?
Is there any way to disable it ? Or do I definitely have to get a bung welded on the new exhaust pipe ?

In the meantime I have the Aracer Smart app installed & QuickBurned a new (suggestion) map from the list (170cc).
But still same deal...

What should be my next move ?
Thx in advance & for reading this oeuvre 馃槄

Tire Wheel Fuel tank Vehicle Automotive fuel system
See less See more
  • Like
Reactions: 1
1 - 2 of 5 Posts
Keihin IF20 NNJ injector (10 holes)
NNJ INJECTOR (10-HOLES / 235CC FLOW RATE) might be a bit large for a 2-valve engine. But I don't know what the next size down is. Would be OK for a freer-breathing 4V head. But according to yuminashi published info a 2V 180cc engine only needs 210CC. But again I don't know if there is one?

My bike 120cc suffers pre-detonation with 130CC but won't rev out with 140CC injector. I bought another 130CC from a different source to see if I got a duff one. If that doesn't work I'll have to fit a fuel controller and reduce the duty cycle of a 140CC injector.
My other alternative is a larger throttle body to increase airflow. But the head is stock.
  • Like
Reactions: 2
NNJ INJECTOR (10-HOLES / 235CC FLOW RATE) might be a bit large for a 2-valve engine. But I don't know what the next size down is. Would be OK for a freer-breathing 4V head. But according to yuminashi published info a 2V 180cc engine only needs 210CC. But again I don't know if there is one?

My bike 120cc suffers pre-detonation with 130CC but won't rev out with 140CC injector. I bought another 130CC from a different source to see if I got a duff one. If that doesn't work I'll have to fit a fuel controller and reduce the duty cycle of a 140CC injector.
My other alternative is a larger throttle body to increase airflow. But the head is stock.
Didn't work.

My bike (not Grom) doesn't like constant 65 kph on small country roads. OK at 80-ish on the highway. I think my problem may be overheating and/or compression too high. Will work on cooling first as that is mechanically easier. That and only using the bike to squirt around town, with no constant low throttle opening.
  • Like
Reactions: 1
1 - 2 of 5 Posts
Top