Honda Grom banner
1 - 9 of 19 Posts

Registered
Joined
10 Posts
Discussion Starter · #1 ·
Just joined the forum and read through some posts but didn't see what I was looking for. I recently acquired a 2015 Grom (Blk) that is in need of quite a few parts to get back roadworthy. I am unfamiliar with a Grom but have quite a few old Hondas I ride and restore. Trying to put it together for my kid but the past owner really beat it up. It runs well but I have not driven it yet. My first order of business (in a fairly long list if needed parts) is at least one rearset (right) and probably both with front pegs. I know I can order new but with so many needed parts wondering if these are items easily found used as I know folks customize their bikes quite a bit. Am I wasting my time shopping used? If anyone has a set they are wanting to part with I would be happy to discuss or if anyone has parts that would fit my bike I would appreciate any help. My list is pretty long...shifter, front indicators, some headlight and dash plastics..and I am sure quite a bit more as I continue to tear into it. Thanks in advance and can't wait to learn about this little bike and take it for a rip!
 

Registered
Joined
10 Posts
Discussion Starter · #4 ·
Welcome Billy and good purchase. I always liked my OG 2015 Grom more than my 2022 so nice one.

I have a pair of complete undamaged original Honda footpeg assemblies for your bike, which I bought for a mere HK$200 (about US$25) with a view to fitting them to my Honda Monkey 125 so I could have a passenger set up. I鈥檝e gone another path with my Monkey so they are sat in an every growing box of spare parts I don鈥檛 need in my spare room.

View attachment 93783
View attachment 93784
View attachment 93785
View attachment 93786
Thank you for the reply. I sent you a message. Thanks!!
 

Registered
Joined
10 Posts
Discussion Starter · #5 ·
Another question. The tail section is missing and the taillight is broken. When I turn the ignition switch on the front indicator lights up. Should the rear indicators have 12v with the ignition on and bike not running? As it stands I have no power back there, I didn't test while running.
 

Registered
Joined
10 Posts
Discussion Starter · #17 ·
You'll have to help me out........I don't see a message you sent me....was it to my email..? is the message on hondagrom.net somewhere...? is this message directly to you, or viewed by others..? can I give you my cell #..? thanks. (somewhat clueless. thanks for your patience)
Sorry, yes I sent you a message on this site. If you click top right the colored square you will see conversations..looks like you have some parts i need
 
1 - 9 of 19 Posts
Top