Honda Grom banner
1 - 4 of 4 Posts

·
Registered
2018 Honda Grom
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,

I have a 2018 Honda Grom. I have owned it from brand new. The bike had no issues until recently. Out of nowhere it started to struggle starting and bog down on cold start. When the grom is on a cold start, if open the throttle a little quick it struggles to rev up or dies. If i roll on the throttle slowly it will rev up. Once it reaches temperature it runs well. The bike is mostly stock.

upgrades
Chimera intake
Ecu flash and tuned
Power Vision Software

the bad.
low compression at 105
Exhaust valve out spec.
spark plug 1 year old

what has been done
ECU reset
ECU flashed back to stock no difference
ECU flashed back to custom tune no difference
TPS reset
Top end rebuilt with oem parts
Fresh fuel

Has anyone had issues similar to this? After all the work the bike still has the same issues.
 

·
Registered
Joined
·
292 Posts
Fix "The Bad" and try again..... I had problems with an injector failing on both my 17 and my girls 15, and they did the exact same thing, but both of our bikes were in tip top running condition (175psi+ compression) at the time. New injectors in both and they run perfect now. Both are also on flashed ECU's, hers is on a DHM flash and mine on a CJR flash.
 

·
Registered
2018 Honda Grom
Joined
·
2 Posts
Discussion Starter · #3 ·
Fix "The Bad" and try again..... I had problems with an injector failing on both my 17 and my girls 15, and they did the exact same thing, but both of our bikes were in tip top running condition (175psi+ compression) at the time. New injectors in both and they run perfect now. Both are also on flashed ECU's, hers is on a DHM flash and mine on a CJR flash.
Thats what I will be testing next. The injector its been crazy. All the bad has been fixed. The bike sits at 160 psi and valves are set in the middle range.
 

·
Registered
Joined
·
292 Posts
Thats what I will be testing next. The injector its been crazy. All the bad has been fixed. The bike sits at 160 psi and valves are set in the middle range.
Compression should get better as the rings bed in more :cool: . This crap drove me nuts for a while til I almost gave up and put a carb on my bike. Right before I was going to do that she got a 143 kit and 140cc injector for hers. When I installed it the thing was doing the same crap, forgot she had bought the injector too. As soon as I installed the new injector it started perfect and you could give it throttle immediately upon starting, and it idles perfectly w/o any throttle input to keep it going. After that, I got a 120cc injector for mine, and the same results..... Could immediately give it throttle on a cold start.
 
1 - 4 of 4 Posts
Top