Clutch issue!!
Close
Login to Your Account
Honda Grom Forum

Clutch issue!!

This is a discussion on Clutch issue!! within the Grom Talk forums, part of the Honda Grom Forums category; So I recently put on a kitaco clutch cover and added a billet clutch plate with 3 stiffer clutch springs and now I can’t seem ...

Results 1 to 3 of 3

Thread: Clutch issue!!

  1. #1
    Junior Member
    This user has no status.
     

    Member #
    31438
    Join Date
    Apr 2019
    Posts
    3

    Clutch issue!!

    So I recently put on a kitaco clutch cover and added a billet clutch plate with 3 stiffer clutch springs and now I can’t seem to get past 35 mph I can shift from 1st to second with ease but once I try to get to 3rd it just revs super high and I can’t seem to get it to shift any ideas?vidmate mobdro word counter
    Last edited by elysse77; Today at 12:46 PM.

  2. #2
    Senior Member
    This user has no status.
     

    Member #
    6719
    Join Date
    Dec 2015
    Posts
    2,370
    Did you make sure the plunger is properly seated in the side case? Or that the billet clutch plate is proper seated in the basket (as well as the springs)?

  3. #3
    Member
    This user has no status.
     

    Member #
    32366
    Join Date
    Aug 2019
    Posts
    39
    My guess is that something is 98% seated which will cause slipping. Take the clutch apart and watch some videos before putting it back together. Many videos show how the pack will look complete, but is not quite seated.

    -S1930

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •