Noise after Kitaco Clutch Cover install?
Close
Login to Your Account
Honda Grom Forum

Noise after Kitaco Clutch Cover install?

This is a discussion on Noise after Kitaco Clutch Cover install? within the Grom Talk forums, part of the Honda Grom Forums category; Hello, new guy here. Sorry for the long post. I have a 2018 Honda Grom SF with 651 miles. This week I installed a Kitaco ...

Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By LordSquirrel

Thread: Noise after Kitaco Clutch Cover install?

  1. #1
    Junior Member
    This user has no status.

    Member #
    32506
    Join Date
    Sep 2019
    Posts
    4

    Noise after Kitaco Clutch Cover install?

    Hello, new guy here. Sorry for the long post. I have a 2018 Honda Grom SF with 651 miles.


    This week I installed a Kitaco Clutch Cover, along with a Takegawa Super Oil Pump, Hard Racing Billet Clutch Plate, and EBC Clutch Springs. Running Motul 300V 10w40 Oil. The install went well. I followed the instructions exactly. Every bolt was torqued to spec. Clutch Springs were seated properly. Clutch free play was adjusted as needed. No surprises.


    Afterwards, while riding the bike I heard what sounded sort of like a whistling/jet engine sound. Not super loud, but noticeable. The sound is only heard when the clutch is engaged and becomes louder as the rpms climb. If you pull in the clutch lever, the sound disappears, even while revving the engine.


    Today, I was able to ride the bike on my street with no helmet, so I could better hear what was going on. The noise sounds like a gear whine sound. I donít remember the bike making this sound previously.


    Two things I observed during the install.


    1. The drive gear on the Takegawa Super Oil had what felt like lots of slop to it. Like it wobbled and sounded like it would rub the back of the oil pump itself. Iím not sure if this is normal for these pumps, but I wasnít left super impressed.


    2. The bearing in the Hard Racing Clutch Plate fit very loosely. You could spin the entire bearing in itís slot. The same bearing also fit pretty loosely in the stock plate too.


    I donít think the oil pump would cause this noise, because it is always spinning regardless of whether or not the clutch is engaged. Maybe the clutch plate bearing could make this noise? Could a gear be damaged?


    Any thoughts? Do any of you have a similar sound from your bikes? Is it normal?

    Reply #9 in this thread, the person talks of a similar sound after installing the Kitaco Clutch Cover. Describes it as a turbo spooling up.

    https://www.hondagrom.net/forums/7-g...-question.html



    I guess it concerns me.

    Thanks. Any help would be greatly appreciated.

  2. #2
    Junior Member
    This user has no status.

    Member #
    32280
    Join Date
    Aug 2019
    Posts
    14
    For what it's worth, I installed that exact same set of parts last week. The bearing was a much tighter fit in the aftermarket clutch plate than in the stock one.

    I also hear some noise but it's not too loud, I didn't think too much of it.

  3. #3
    Junior Member
    This user has no status.
    OzGromADEL333's Avatar
    Member #
    32434
    Join Date
    Aug 2019
    Location
    Australia - Adelaide
    Odometer
    7000
    Posts
    1
    Quote Originally Posted by BrawndoGrom View Post
    Hello, new guy here. Sorry for the long post. I have a 2018 Honda Grom SF with 651 miles.


    This week I installed a Kitaco Clutch Cover, along with a Takegawa Super Oil Pump, Hard Racing Billet Clutch Plate, and EBC Clutch Springs. Running Motul 300V 10w40 Oil. The install went well. I followed the instructions exactly. Every bolt was torqued to spec. Clutch Springs were seated properly. Clutch free play was adjusted as needed. No surprises.


    Afterwards, while riding the bike I heard what sounded sort of like a whistling/jet engine sound. Not super loud, but noticeable. The sound is only heard when the clutch is engaged and becomes louder as the rpms climb. If you pull in the clutch lever, the sound disappears, even while revving the engine.


    Today, I was able to ride the bike on my street with no helmet, so I could better hear what was going on. The noise sounds like a gear whine sound. I don’t remember the bike making this sound previously.


    Two things I observed during the install.


    1. The drive gear on the Takegawa Super Oil had what felt like lots of slop to it. Like it wobbled and sounded like it would rub the back of the oil pump itself. I’m not sure if this is normal for these pumps, but I wasn’t left super impressed.


    2. The bearing in the Hard Racing Clutch Plate fit very loosely. You could spin the entire bearing in it’s slot. The same bearing also fit pretty loosely in the stock plate too.


    I don’t think the oil pump would cause this noise, because it is always spinning regardless of whether or not the clutch is engaged. Maybe the clutch plate bearing could make this noise? Could a gear be damaged?


    Any thoughts? Do any of you have a similar sound from your bikes? Is it normal?

    Reply #9 in this thread, the person talks of a similar sound after installing the Kitaco Clutch Cover. Describes it as a turbo spooling up.

    https://www.hondagrom.net/forums/7-g...-question.html



    I guess it concerns me.

    Thanks. Any help would be greatly appreciated.
    I installed one of these years ago and had same noise. Oil pump flow has increased by 40% so hearing a whooshing noise is normal. Just put a loud exhaust and you'll never hear it again lol. Get a catch can and oil cooler installed and start riding it like its stolen lmao

  4. Remove Advertisements
    HondaGrom.net
    Advertisements
     

  5. #4
    Junior Member
    This user has no status.
    PitBike's Avatar
    Member #
    32492
    Join Date
    Sep 2019
    Posts
    1
    #10 in that thread is your answer

  6. #5
    Junior Member
    This user has no status.

    Member #
    32506
    Join Date
    Sep 2019
    Posts
    4
    Quote Originally Posted by OzGromADEL333 View Post
    I installed one of these years ago and had same noise. Oil pump flow has increased by 40% so hearing a whooshing noise is normal. Just put a loud exhaust and you'll never hear it again lol. Get a catch can and oil cooler installed and start riding it like its stolen lmao
    Thanks for the replies everyone.

    I guess I’m not convinced it is the oil pump, because the pump is always spinning. This noise goes away as soon as the clutch lever is pulled in. You can then rev the motor to the moon and the noise will not be present until the clutch is released again.

    I do have a loud exhaust though and agree with your advice to ride it like I stole it...lol!

    Quote Originally Posted by PitBike View Post

    #10 in that thread is your answer
    Reply #10 in that thread, mentions there being more whine created by flat cut gears when there is less load on them. In my case, I think the gears or whatever seems to be quiet when the is no load and whining when the clutch lever is released and the load picks up.
    Last edited by BrawndoGrom; 09-08-2019 at 02:04 PM. Reason: Correcting mistakes

  7. #6
    Senior Member
    This user has no status.
    tooter's Avatar
    Member #
    30592
    Join Date
    Jan 2019
    Location
    unincorporated rural Los Angeles County
    Odometer
    2000
    Posts
    697
    Reply #10 in that thread, mentions there being more whine created by flat cut gears when there is less load on them.
    I hear the whine whenever I'm coasting to a stop. Sounds exactly like flat cut gears in an unloaded situation to me. I also hear the clutch basket rattling at idle. I believe that without the heavy spinner absorbing the power stokes of the engine, those little pulsing accelerations and decelerations of the crankshaft get transferred to the basket causing the clutch plates rattle.
    2018 GROM: Modified for reliability longevity gas mileage... and fun.

  8. #7
    Junior Member
    This user has no status.

    Member #
    32506
    Join Date
    Sep 2019
    Posts
    4
    I don’t notice the clutch basket rattling on my bike, but it has low miles at this point, so maybe that makes a difference.

    I think it is the musician in me. I am very sensitive to changes in sound. With that said, I wish I knew definitively what was causing this. I feel like something is off.

    A friend suggested that maybe the Motul 300V 10w40 oil could be causing this. I’m not sure if oil could make that big of a difference in sound or not.

    While I don’t think it is the oil pump causing this sound, has anyone else noticed the drive gear on their Takegawa Oil Pump rubbing up against the backside of the pump? As I stated previously, I wasn’t super impressed. Expected the Takegawa Pump to be high quality. Maybe due to the additional thickness of the pump there is less clearance?

    This is the only Takegawa Oil Pump I have ever held, so I have nothing to compare it to other than the stock pump. It didn’t inspire confidence. If it fails, bad things would happen.

  9. #8
    Senior Member
    This user has no status.
    tooter's Avatar
    Member #
    30592
    Join Date
    Jan 2019
    Location
    unincorporated rural Los Angeles County
    Odometer
    2000
    Posts
    697
    Quote Originally Posted by BrawndoGrom View Post
    I don’t notice the clutch basket rattling on my bike, but it has low miles at this point, so maybe that makes a difference.
    Mine has over 5,000 miles. It's normal for things to loosen up and rattle a little. It's not the sound of anything breaking, just typical wear.
    2018 GROM: Modified for reliability longevity gas mileage... and fun.

  10. #9
    Senior Member
    is a squirrel
    LordSquirrel's Avatar
    Member #
    28458
    Join Date
    Apr 2018
    Location
    Cleveland
    Posts
    264
    You referenced my post about the noise. It still makes the noise, but I've had no issues. I think it's just as Tooter said about the gears. I have a good number of miles on it and have taken the cover off to get in there for other things and it still looks perfect. It's just a noise it makes. I wouldn't lose sleep over it.

    Also I haven't noticed anything with the Takegawa oil pump. It was a tight fit when I first installed it, but that's about it. It is a quality part and I have nothing but good experiences with Takegawa.
    tooter likes this.
    2014 Grom
    Takegawa 143cc kit with S stage cam
    Kitaco clutch cover
    Takegawa oil pump with SUP modded catch
    PCX 150 injector
    SMR 6 disc clutch and 60% springs
    Koso clutch plate
    Opmid temp gauge
    Innovate MTX-L Plus AFR gauge
    EFIE
    Ebay exhaust, intake, and a bunch of other parts
    Seat Concepts seat
    OTB chain adjusters w/ spool
    14T/36T sprockets
    Pirelli SL26 tires

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Tags for this Thread