All Balls Racing steering bearing kit - steering feels weird
Close
Login to Your Account
Honda Grom Forum

All Balls Racing steering bearing kit - steering feels weird

This is a discussion on All Balls Racing steering bearing kit - steering feels weird within the Grom Performance forums, part of the Honda Grom Garage category; Just finished installing the All Balls Racing steering bearing kit in my 2018 Grom and the steering feels a little weird. Specifically, near the straight ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Like Tree1Likes

Thread: All Balls Racing steering bearing kit - steering feels weird

  1. #1
    Member
    This user has no status.
     

    Member #
    31676
    Join Date
    May 2019
    Posts
    91

    All Balls Racing steering bearing kit - steering feels weird

    Just finished installing the All Balls Racing steering bearing kit in my 2018 Grom and the steering feels a little weird. Specifically, near the straight position, it feels like it wants to wobble a little rather than self-centering perfectly.

    I played with the adjustment nut a bit and realized that I had it too tight initially (I misread the factory manual and left it at 20 ft-lbs, the first time around). After reducing it to 1-2 ft-lbs tops, it feels better, but still definitely feels as if it wants to wander a bit. Is this just something that feels a little different the first few rides or does it sound like something is wrong? Anyone else have similar feedback after installing this kit?

  2. #2
    Senior Member
    is Living the Dream
     

    Member #
    457
    Join Date
    Jun 2013
    Location
    San Jose Calif
    Posts
    8,054
    I have 2 2014 groms and I ride it like a stole them with a combined mileage of 25,000 miles with zero issues with the stock OEM neck bearings, sometimes it is better to leave some things alone.

    The wheel bearings should be changed out with All balls bearings

  3. #3
    Senior Member
    This user has no status.
     

    Member #
    5807
    Join Date
    Jul 2015
    Location
    San Diego
    Posts
    479
    Did you pack the bearings, check tire pressure, and tune your suspension(if possible)? I really have no say about the bearing kit you bought, but I always felt like the stock grom had a little bit of wobble. It is a light weight bike so the wobble might be more noticeable after installing the new bearings. Maybe its time to buy a steering damper?

  4. Remove Advertisements
    HondaGrom.net
    Advertisements
     

  5. #4
    Member
    This user has no status.
     

    Member #
    31676
    Join Date
    May 2019
    Posts
    91
    Bearings were packed perfectly. Tire pressure will be checked today but should still be correct from a week or so back. Suspension is Ohlins fixed and felt fine pre-bearings. I'm going to go on a short ride again today and see if they feel any better with the 1.5 ish ft-lbs of torque on the adjuster.

  6. #5
    Member
    This user has no status.
     

    Member #
    31676
    Join Date
    May 2019
    Posts
    91
    Tire pressure was fine. I went for a real ride today and decel and low-speed neutral rolling are the two places where there is a big difference. I suspect the difference in bearing style is the cause. It doesn't feel dangerous, but it does feel a little more loose than before.
    asume likes this.

  7. #6
    Member
    This user has no status.
     

    Member #
    31676
    Join Date
    May 2019
    Posts
    91
    Am I really the only guy running these bearings? I called ABR yesterday and they haven't called back yet. I strongly suspect the taper bearings just have less resistance off-center at low speeds (leading to the wallowing feeling) but I'd sure like to confirm this with someone else who installed the kit.

    I'll go out on a limb here - anyone in the Portland area want a ABR steering kit installed, free of charge? I purchased a second one thinking I'd be replacing the original but I've got all the stem tools to R&R the bearings properly and could probably knock it out in an hour.

  8. #7
    Senior Member
    This user has no status.
     
    obijuanito's Avatar
    Member #
    4704
    Join Date
    Jan 2015
    Posts
    422
    Quote Originally Posted by mrsaturn7085 View Post
    Am I really the only guy running these bearings? I called ABR yesterday and they haven't called back yet. I strongly suspect the taper bearings just have less resistance off-center at low speeds (leading to the wallowing feeling) but I'd sure like to confirm this with someone else who installed the kit.

    I'll go out on a limb here - anyone in the Portland area want a ABR steering kit installed, free of charge? I purchased a second one thinking I'd be replacing the original but I've got all the stem tools to R&R the bearings properly and could probably knock it out in an hour.
    Installed a bunch of them and NEVER had such issue...

    Enviat des del meu LG-H870 usant Tapatalk

  9. #8
    Member
    This user has no status.
     

    Member #
    31576
    Join Date
    May 2019
    Posts
    53
    My WR450 manual says 5.1 ft/lb for the 2nd torque spec. I took it apart to grease it one time, didn't have a spanner for a torque wrench so I just guessed. It felt scary so I tightened it a little more and it felt good. Maybe 1.5 ft/lb isn't enough if the stock bearings are a different type.

  10. #9
    Member
    This user has no status.
     

    Member #
    31676
    Join Date
    May 2019
    Posts
    91
    I'm wondering if it's the front tire... it might not have been noticeable under the stock bearing but now maybe I'm feeling an out of balance or mis-mounted tire?

  11. #10
    Member
    This user has no status.
     

    Member #
    31676
    Join Date
    May 2019
    Posts
    91
    Well, I changed the All Balls kit out for ANOTHER All Balls kit. Turns out I did have the bearing races on the wrong bearings, but the races are identical aside from the markings so it shouldn't make a difference.

    Unfortunately, the new kit feels the EXACT same, if not worse. It's downright scary at low speeds, and feels almost like a mini tank-slapper.

    Probably gonna take it all apart again and just put the stock parts back. I *REALLY* hope it doesn't persist after that, as the ABR bearing races are a monster of a job to remove.

Page 1 of 2 1 2 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •