Need help again
Close
Login to Your Account
Honda Grom Forum

Need help again

This is a discussion on Need help again within the Site Help and Support forums, part of the Honda Grom News category; My 235 Finbro engine had these oil leaks marks a month ago, "right side" I can't see where it came from, no new ones since ...

Results 1 to 10 of 10

Thread: Need help again

  1. #1
    Senior Member
    This user has no status.
     

    Member #
    5746
    Join Date
    Jul 2015
    Location
    San Francisco
    Odometer
    1142
    Posts
    138

    Need help again

    My 235 Finbro engine had these oil leaks marks a month ago, "right side" I can't see where it came from,
    no new ones since , any clue?

  2. #2
    Senior Member
    is Loving the Big Bore life!
     
    estallings15's Avatar
    Member #
    7251
    Join Date
    Apr 2016
    Location
    From Texas. Lived in Southern California for a bit. Currently in Central Florida.
    Odometer
    3100
    Posts
    1,267
    Has your oil level changed at all? Occasionally I still get oil coming out of my breather filter because I never installed a real catch can. I have a soft spot for an airbox filling the hole between the side fairings. Don't know why.

    What's your crankcase breather setup like?
    Koso 170
    Finbro Big Valve head & TB
    Takegawa S-Stage Cam
    PCV/WB2

  3. #3
    Senior Member
    This user has no status.
     

    Member #
    5746
    Join Date
    Jul 2015
    Location
    San Francisco
    Odometer
    1142
    Posts
    138
    Need help again-img_4174.jpg

  4. Remove Advertisements
    HondaGrom.net
    Advertisements
     

  5. #4
    Senior Member
    This user has no status.
     

    Member #
    5746
    Join Date
    Jul 2015
    Location
    San Francisco
    Odometer
    1142
    Posts
    138
    I have no catch can or anything , but this has not happened since.

  6. #5
    Senior Member
    This user has no status.
     

    Member #
    5746
    Join Date
    Jul 2015
    Location
    San Francisco
    Odometer
    1142
    Posts
    138
    When I changed the oil, I put the whole Quart of oil in. Oil level has not changed since this happened.
    Last edited by 8701michael; 02-17-2017 at 04:43 AM.

  7. #6
    Senior Member
    is Loving the Big Bore life!
     
    estallings15's Avatar
    Member #
    7251
    Join Date
    Apr 2016
    Location
    From Texas. Lived in Southern California for a bit. Currently in Central Florida.
    Odometer
    3100
    Posts
    1,267
    My first check would be the oil lines and banjo bolts. Then I'd pull the lower fairing and double check all around the gasket for the clutch cover.

    Edit: Not sure what kind of oil you're using, but conventional oil is well known for creating false seals and plugging small leaks.
    Koso 170
    Finbro Big Valve head & TB
    Takegawa S-Stage Cam
    PCV/WB2

  8. #7
    Senior Member
    This user has no status.
     

    Member #
    5746
    Join Date
    Jul 2015
    Location
    San Francisco
    Odometer
    1142
    Posts
    138
    Maybe the crankcase breather is a tube???? Don't know, probably whatever stock is????

  9. #8
    Senior Member
    This user has no status.
     

    Member #
    5746
    Join Date
    Jul 2015
    Location
    San Francisco
    Odometer
    1142
    Posts
    138
    Ah, maybe, I changed the oil lines.
    Sorry everyone, maybe crying wolf.

  10. #9
    Senior Member
    This user has no status.
     

    Member #
    5746
    Join Date
    Jul 2015
    Location
    San Francisco
    Odometer
    1142
    Posts
    138
    Quote Originally Posted by estallings15 View Post
    My first check would be the oil lines and banjo bolts. Then I'd pull the lower fairing and double check all around the gasket for the clutch cover.

    Edit: Not sure what kind of oil you're using, but conventional oil is well known for creating false seals and plugging small leaks.
    Thank you.

  11. #10
    Senior Member
    This user has no status.
     
    obijuanito's Avatar
    Member #
    4704
    Join Date
    Jan 2015
    Posts
    243
    Clean all area with water and some degreaser, check oil level, start bike, let it idle till you see where it comes from.

    Enviat des del meu LG-V500 usant Tapatalk

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •